Newest releases stop listening

Topics: faq
Oct 9, 2009 at 3:08 PM

Hi there!

I am using your WebServer (desktop) since some month and it seemed everything OK by using the release 19869.

A short ago I have tried to download the latest release (26815) and something is not working as before...just to be sure, I also tried to refer the old 19869 and the behavior is correct.

The problem is really simple.

Consider using the WebServer for hosting normal html pages (with some image too) in Win XP-Pro, port 80, IIS turned down.

At each request the server tries to load the proper file from disk and send back to the browser...very clean, any problem for weeks (as far I've used the 19869).

The problem is the following:

  1. start the web server;
  2. open the browser and go to the requested page: it displays correctly;
  3. close the browser, but not the web server;
  4. re-open the browser and go to the same page as before: the page won't appears.

Now stop and start the web server and the page seems working again.

Please note that problem appears by using Firefox 3.5 o Chrome 3.0. The problem won't appears if you try with IE8.

I also noticed that, in the condition (4), there's not any request event firing: the server seems "as stopped", but the socket (netstat).

Any idea?

Oct 9, 2009 at 3:28 PM

I noticed that too. Here is the ticket. In my description of the problem, I show a hack that will cause your servers to continue to function, but it is certainly not an ideal solution. Maybe you can come up with a more robust patch than I could until the authors fix.

 

http://webserver.codeplex.com/WorkItem/View.aspx?WorkItemId=5099

 

 

Oct 9, 2009 at 4:22 PM

Dear PlasticLizard,

thank you for your answer: I didn't notice the ticked.

I've tried to compare the trunk sources, but there are too many differences.

My case is not so important and I may keep the old release til the author will publish a new one.

I had planned to use this web server for a real-system, but (for many reasons) the development has turned to Linux (C++). This (very cool) web server is still used, but only within lab environment.

Thanks again.

Cheers

Coordinator
Nov 1, 2009 at 10:47 AM

Have anyone of you tried the trunk?

Nov 2, 2009 at 5:22 AM

Hello there!

I *only used* the trunk...

Coordinator
Nov 2, 2009 at 6:26 AM

Did you try the changes I did yesterday?...

Nov 2, 2009 at 8:00 AM

Hi...I've tried the rev 30408 right now and it seems working as well.

In this moment I can't perform a deeper test, but this problem appears to be solved, as far I think.

Thank you so much for your work.

Cheers.